const regex = /\[phy\]\[[^\]\[]*\]\[([^\]\[]*)\]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[phy\\]\\[[^\\]\\[]*\\]\\[([^\\]\\[]*)\\]', 'gm')
const str = `case 1 is good [phy][hu][get] my dog is [hy][iu][put] [phy][hu][gotcha]`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);