import Foundation
let pattern = #"\[phy\]\[[^\]\[]*\]\[([^\]\[]*)\]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"case 1 is good [phy][hu][get] my dog is [hy][iu][put] [phy][hu][gotcha]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)