$re = '/\[(\s*[0-9]+\s*),(\s*[0-9]+\s*)\]\s*(>=|<=|==|>|<)\s*([0-9]+)\s*(\|\||\&\&)*/m';
$str = '[1,2]==3 || [1,110] >= 2 && [1,200] > 3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);