import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<img.*?src=[\"|'](.*?)[\"|']";
final String string = "<img src='path/to/image/name.jpg' />\n"
+ "<img src='path/to/image/name.jpg' alt=\"name here\"/><p>test card 22</p>\n"
+ "<img src=\"path/to/image/name.jpg\"/><p>test card 22</p>\n"
+ "<img src=\"http://media.cheggcdn.com/media%2Fd08%2Fd087a4d3-8e4e-4e42-8cf0-2b03238a33ef%2Fimage\"/><p>test card 22</p>\n"
+ "<img src='http://media.cheggcdn.com/media%2Fd08%2Fd087a4d3-8e4e-4e42-8cf0-2b03238a33ef%2Fimage'/><p>test card 22</p>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}