// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<img.*?src=["|'](.*?)["|']"#).unwrap();
let string = "<img src='path/to/image/name.jpg' />
<img src='path/to/image/name.jpg' alt=\"name here\"/><p>test card 22</p>
<img src=\"path/to/image/name.jpg\"/><p>test card 22</p>
<img src=\"http://media.cheggcdn.com/media%2Fd08%2Fd087a4d3-8e4e-4e42-8cf0-2b03238a33ef%2Fimage\"/><p>test card 22</p>
<img src='http://media.cheggcdn.com/media%2Fd08%2Fd087a4d3-8e4e-4e42-8cf0-2b03238a33ef%2Fimage'/><p>test card 22</p>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}