use strict;
my $str = '<img src=\'path/to/image/name.jpg\' />
<img src=\'path/to/image/name.jpg\' alt="name here"/><p>test card 22</p>
<img src="path/to/image/name.jpg"/><p>test card 22</p>
<img src="http://media.cheggcdn.com/media%2Fd08%2Fd087a4d3-8e4e-4e42-8cf0-2b03238a33ef%2Fimage"/><p>test card 22</p>
<img src=\'http://media.cheggcdn.com/media%2Fd08%2Fd087a4d3-8e4e-4e42-8cf0-2b03238a33ef%2Fimage\'/><p>test card 22</p>';
my $regex = qr/<img.*?src=["|'](.*?)["|']/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}