package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\^\s*(\w.*)\.`)
var str = `g: x and: y
Transcript show: x; show: y.
^x+y.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}