$re = '/\^\s*(\w.*)\./';
$str = 'g: x and: y
Transcript show: x; show: y.
^x+y.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);