using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Voldemort(?=[^“”]*”)";
string input = @"“they say Voldemort is on the move.” Said, Ron. But Harry knew Voldemort was taking a well-earned nap.
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase | RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}