const regex = /Voldemort(?=[^“”]*”)/gmiu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Voldemort(?=[^“”]*”)', 'gmiu')
const str = `“they say Voldemort is on the move.” Said, Ron. But Harry knew Voldemort was taking a well-earned nap.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}