re = /Voldemort(?=[^“”]*”)/mi
str = '“they say Voldemort is on the move.” Said, Ron. But Harry knew Voldemort was taking a well-earned nap.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end