using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a[^>]+>\K([\w &]{1,10})(?=<\/a>)";
string input = @"<a href=""https://website.com"">0123456789</a>
<a href=""https://website.com"">less</a>
<a href=""https://website.com"">0123456789tooMuch</a>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}