$re = '/<a[^>]+>\K([\w &]{1,10})(?=<\/a>)/m';
$str = '<a href="https://website.com">0123456789</a>
<a href="https://website.com">less</a>
<a href="https://website.com">0123456789tooMuch</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);