const regex = /<a[^>]+>\K([\w &]{1,10})(?=<\/a>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a[^>]+>\\K([\\w &]{1,10})(?=<\\\/a>)', 'gm')
const str = `<a href="https://website.com">0123456789</a>
<a href="https://website.com">less</a>
<a href="https://website.com">0123456789tooMuch</a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}