using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-z]+\.([a-z]+[0-9]*)@epn.edu.ec$";
string input = @"pepito.delospalotes@epn.edu.ec
pepito.@epn.edu.ec";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}