re = /^[a-z]+\.([a-z]+[0-9]*)@epn.edu.ec$/m
str = 'pepito.delospalotes@epn.edu.ec
pepito.@epn.edu.ec'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end