$re = '/^[a-z]+\.([a-z]+[0-9]*)@epn.edu.ec$/m';
$str = 'pepito.delospalotes@epn.edu.ec
pepito.@epn.edu.ec';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);