import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:(\\d)(?!\\1+))(\\d))(?:(?:(\\d)(?!\\3+))(\\d))(?:(?:(\\d)(?!\\5+))(\\d))$";
final String string = "12345678\n"
+ "123456\n"
+ "122334\n"
+ "123445\n"
+ "111111\n"
+ "112233\n"
+ "121212\n"
+ "000000\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}