const regex = /^(?:(?:(\d)(?!\1+))(\d))(?:(?:(\d)(?!\3+))(\d))(?:(?:(\d)(?!\5+))(\d))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?:(\\d)(?!\\1+))(\\d))(?:(?:(\\d)(?!\\3+))(\\d))(?:(?:(\\d)(?!\\5+))(\\d))$', 'gm')
const str = `12345678
123456
122334
123445
111111
112233
121212
000000
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}