re = /^(?:(?:(\d)(?!\1+))(\d))(?:(?:(\d)(?!\3+))(\d))(?:(?:(\d)(?!\5+))(\d))$/m
str = '12345678
123456
122334
123445
111111
112233
121212
000000
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end