import re
regex = re.compile(r"(?<=Prize\n)(.+)", flags=re.MULTILINE)
test_str = (" Invoice\n\n"
"CK DEF Pvt ltd Invoice Number: 14523687\n"
" Account: Karnataka Bank\n"
" Account Number: 42568965113124\n\n"
" Date: 03-08-2021\n\n"
"Company: PRENDON RICARD AUST (WINE) 705328\n"
"Email: Cherrychethan22@gmail.com\n"
"From: Australia PTY LTD\n\n\n\n"
"Store# Name and address of the store\n\n"
"3456 LX WORD SQUARE\n"
" 650 gorge SP\n"
" Bangalore\n"
" 573102\n\n"
"Contact Ph: 2 35 633 125 568\n"
"Purchase order number: 12345678\n"
"Liquor License: LIPQ274013486\n\n"
"Item Description UOM Qty Size Prize\n"
"258947561237 Str huge barrel 7500 ml CARTOM 1 7500 133.15\n"
"986452137954 Str HUGO Chardony 750 ml CARTOM 1 750 11.4\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")