#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?s)<Directory />\n(.*?)\n</Directory>"
Local $sString = "<Directory />" & @CRLF & _
" Options FollowSymLinks" & @CRLF & _
" AllowOverride None" & @CRLF & _
" Require all denied" & @CRLF & _
" Order deny,allow" & @CRLF & _
" Deny from all" & @CRLF & _
"</Directory>" & @CRLF & _
"<Directory /usr/share>" & @CRLF & _
" AllowOverride None" & @CRLF & _
" Require all granted" & @CRLF & _
"</Directory>" & @CRLF & _
"<Directory /var/www/>" & @CRLF & _
" Options Indexes FollowSymLinks" & @CRLF & _
" AllowOverride None" & @CRLF & _
" Require all granted" & @CRLF & _
"</Directory>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")