re = /(?s)<Directory \/>\n(.*?)\n<\/Directory>/m
str = '<Directory />
Options FollowSymLinks
AllowOverride None
Require all denied
Order deny,allow
Deny from all
</Directory>
<Directory /usr/share>
AllowOverride None
Require all granted
</Directory>
<Directory /var/www/>
Options Indexes FollowSymLinks
AllowOverride None
Require all granted
</Directory>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end