import re
regex = re.compile(r"(?s)<Directory />\n(.*?)\n</Directory>", flags=re.MULTILINE)
test_str = ("<Directory />\n"
" Options FollowSymLinks\n"
" AllowOverride None\n"
" Require all denied\n"
" Order deny,allow\n"
" Deny from all\n"
"</Directory>\n"
"<Directory /usr/share>\n"
" AllowOverride None\n"
" Require all granted\n"
"</Directory>\n"
"<Directory /var/www/>\n"
" Options Indexes FollowSymLinks\n"
" AllowOverride None\n"
" Require all granted\n"
"</Directory>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")