using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=(.*\n){0,3}.*Word1)(?=(.*\n){0,3}.*Word2).*";
string input = @"1. apple Word1
banana Word2
1. apple Word1
banana Word2
1. apple Word1
banana Word2";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}