$re = '/^(?=(.*\n){0,3}.*Word1)(?=(.*\n){0,3}.*Word2).*/m';
$str = '1. apple Word1
banana Word2
1. apple Word1
banana Word2
1. apple Word1
banana Word2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);