re = /^(?=(.*\n){0,3}.*Word1)(?=(.*\n){0,3}.*Word2).*/m
str = '1. apple Word1
banana Word2
1. apple Word1
banana Word2
1. apple Word1
banana Word2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end