const regex = /(<.+?)(?<=\s)on[a-z]+\s*=\s*(?:(['"])(?!\2).+?\2|(?:\S+?\(.*?\)(?=[\s>])))(.*?>)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<.+?)(?<=\\s)on[a-z]+\\s*=\\s*(?:([\'"])(?!\\2).+?\\2|(?:\\S+?\\(.*?\\)(?=[\\s>])))(.*?>)', 'gi')
const str = `<meta name="keywords" content="keyword1, keyword2, keyword3">
<a href="something" onclick= "bad()">text</a> onclick not in tags
<a href="something" onclick =bad()>text</a>
<a href="something" onclick=bad('test')>text</a>
<a href="something" onclick=bad("test")>text</a>
<a href="something" onclick="bad()" >text</a>
<a href="http://mydomain.com/index.php?oninaval=12" class="titi">text</a>
What if I write john+onelia=love forever?
<a href="something" onclick="bad()">text</a> onclick not in tags
<a href="something" onclick=bad()>text</a>
<a href="something" onclick="bad()" >text</a>
<a href="something" onclick=a++ >text</a>
onclick="asd <span class="myclass"> not in tag too.</span>
<!-- onclick=" --><a href="something" onclick= "bad()">text</a>
<textarea><enter onclick="dothat()" text here></textarea>
yoko ono="john lennon"
<img src="/images/img1.jpg" alt="onclick=thegood() onclick=thebad() "/>
<img alt="onclick=" src=/images/theugly.jpg> the most important part of the message <p class="disappears"></p>
<a href="" onmouseover=a=7>button1</a>
<a href="something" onclick=a++>text</a>
<a href="something" onclick=a<<1>text</a>
<a href="" onmouseover="alert(a);">button2</a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}