import Foundation
let pattern = #"(<.+?)(?<=\s)on[a-z]+\s*=\s*(?:(['"])(?!\2).+?\2|(?:\S+?\(.*?\)(?=[\s>])))(.*?>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
<meta name="keywords" content="keyword1, keyword2, keyword3">
<a href="something" onclick= "bad()">text</a> onclick not in tags
<a href="something" onclick =bad()>text</a>
<a href="something" onclick=bad('test')>text</a>
<a href="something" onclick=bad("test")>text</a>
<a href="something" onclick="bad()" >text</a>
<a href="http://mydomain.com/index.php?oninaval=12" class="titi">text</a>
What if I write john+onelia=love forever?
<a href="something" onclick="bad()">text</a> onclick not in tags
<a href="something" onclick=bad()>text</a>
<a href="something" onclick="bad()" >text</a>
<a href="something" onclick=a++ >text</a>
onclick="asd <span class="myclass"> not in tag too.</span>
<!-- onclick=" --><a href="something" onclick= "bad()">text</a>
<textarea><enter onclick="dothat()" text here></textarea>
yoko ono="john lennon"
<img src="/images/img1.jpg" alt="onclick=thegood() onclick=thebad() "/>
<img alt="onclick=" src=/images/theugly.jpg> the most important part of the message <p class="disappears"></p>
<a href="" onmouseover=a=7>button1</a>
<a href="something" onclick=a++>text</a>
<a href="something" onclick=a<<1>text</a>
<a href="" onmouseover="alert(a);">button2</a>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)