package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)http.*zippyshare.*\.html`)
var str = `/b/ - Catalog https://55chan.org/b/catalog.html
Punch! Fansubs https://punchsubs.net/projeto/504/2
Zippyshare.com - PUNCH_Mushishi_-_06_SD.mkv https://www36.zippyshare.com/v/fBA0yWY3/file.html
Zippyshare.com - PUNCH_Mushishi_-_05_SD.mkv https://www26.zippyshare.com/v/9mWT8v7X/file.html
Zippyshare.com - PUNCH_Mushishi_-_04_SD.mkv https://www94.zippyshare.com/v/zLFWM4dC/file.html
Zippyshare.com - PUNCH_Mushishi_-_03_SD.mkv https://www18.zippyshare.com/v/7p1LRySL/file.html
Zippyshare.com - PUNCH_Mushishi_-_02_SD_REV3.mkv https://www95.zippyshare.com/v/nkMUaqNJ/file.html
Zippyshare.com - PUNCH_Mushishi_-_01_SD_REV3.mkv https://www31.zippyshare.com/v/2EkNKEwD/file.html
Cópia de OneClickRun.ipynb - Colaboratory https://colab.research.google.com/drive/1cSKxX5c2R4SLsdcndRoBzXgmZ2Fkd-sR?authuser=3#scrollTo=Mfg4A3KRjESb
Resultados da pesquisa por “Mushishi” – OldAge Subs https://oldagesubs.com/?s=Mushishi&submit=Pesquisar
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}