import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "http.*zippyshare.*\\.html";
final String string = "/b/ - Catalog https://55chan.org/b/catalog.html\n"
+ "Punch! Fansubs https://punchsubs.net/projeto/504/2\n"
+ "Zippyshare.com - PUNCH_Mushishi_-_06_SD.mkv https://www36.zippyshare.com/v/fBA0yWY3/file.html\n"
+ "Zippyshare.com - PUNCH_Mushishi_-_05_SD.mkv https://www26.zippyshare.com/v/9mWT8v7X/file.html\n"
+ "Zippyshare.com - PUNCH_Mushishi_-_04_SD.mkv https://www94.zippyshare.com/v/zLFWM4dC/file.html\n"
+ "Zippyshare.com - PUNCH_Mushishi_-_03_SD.mkv https://www18.zippyshare.com/v/7p1LRySL/file.html\n"
+ "Zippyshare.com - PUNCH_Mushishi_-_02_SD_REV3.mkv https://www95.zippyshare.com/v/nkMUaqNJ/file.html\n"
+ "Zippyshare.com - PUNCH_Mushishi_-_01_SD_REV3.mkv https://www31.zippyshare.com/v/2EkNKEwD/file.html\n"
+ "Cópia de OneClickRun.ipynb - Colaboratory https://colab.research.google.com/drive/1cSKxX5c2R4SLsdcndRoBzXgmZ2Fkd-sR?authuser=3#scrollTo=Mfg4A3KRjESb\n"
+ "Resultados da pesquisa por “Mushishi” – OldAge Subs https://oldagesubs.com/?s=Mushishi&submit=Pesquisar\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}