# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"http.*zippyshare.*\.html"
test_str = ("/b/ - Catalog https://55chan.org/b/catalog.html\n"
"Punch! Fansubs https://punchsubs.net/projeto/504/2\n"
"Zippyshare.com - PUNCH_Mushishi_-_06_SD.mkv https://www36.zippyshare.com/v/fBA0yWY3/file.html\n"
"Zippyshare.com - PUNCH_Mushishi_-_05_SD.mkv https://www26.zippyshare.com/v/9mWT8v7X/file.html\n"
"Zippyshare.com - PUNCH_Mushishi_-_04_SD.mkv https://www94.zippyshare.com/v/zLFWM4dC/file.html\n"
"Zippyshare.com - PUNCH_Mushishi_-_03_SD.mkv https://www18.zippyshare.com/v/7p1LRySL/file.html\n"
"Zippyshare.com - PUNCH_Mushishi_-_02_SD_REV3.mkv https://www95.zippyshare.com/v/nkMUaqNJ/file.html\n"
"Zippyshare.com - PUNCH_Mushishi_-_01_SD_REV3.mkv https://www31.zippyshare.com/v/2EkNKEwD/file.html\n"
"Cópia de OneClickRun.ipynb - Colaboratory https://colab.research.google.com/drive/1cSKxX5c2R4SLsdcndRoBzXgmZ2Fkd-sR?authuser=3#scrollTo=Mfg4A3KRjESb\n"
"Resultados da pesquisa por “Mushishi” – OldAge Subs https://oldagesubs.com/?s=Mushishi&submit=Pesquisar\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.