const regex = /(\d{0,3}\.\d{3}\/)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{0,3}\\.\\d{3}\\\/)', 'g')
const str = `PING 144.76.158.35 (144.76.158.35) 56(84) bytes of data.
--- 144.76.158.35 ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 4006ms
rtt min/avg/max/mdev = 13.576/13.728/13.969/0.173 ms`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}