package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\w*[a-zA-Z_]\w*)?$`)
var str = `expression123
123expression
exp123ression
1235234567544
expression$123
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}