re = /^(?:\w*[a-zA-Z_]\w*)?$/m
str = 'expression123
123expression
exp123ression
1235234567544
expression$123
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end