import re
regex = re.compile(r"^(?:\w*[a-zA-Z_]\w*)?$", flags=re.MULTILINE)
test_str = ("expression123\n"
"123expression\n"
"exp123ression\n\n"
"1235234567544\n"
"expression$123\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")