#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)string_start (.*) string_middle (.*) string_end"
Local $sString = "string_start part 1 text string_middle part 2 text string_end"
Local $sSubst = "string_start new part 1 string_middle new part 2 string_end"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)