# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"string_start (.*) string_middle (.*) string_end"
test_str = "string_start part 1 text string_middle part 2 text string_end"
subst = "string_start new part 1 string_middle new part 2 string_end"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.