re = /string_start (.*) string_middle (.*) string_end/m
str = 'string_start part 1 text string_middle part 2 text string_end'
subst = 'string_start new part 1 string_middle new part 2 string_end'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result