import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "customer name is ([\\w\\s]*?(?=(?:and|or|$)))?(?:(?:(?:and|or) customer id is )(\\d*)|c)? ?(?:(?:(?:and|or) policy id is ([a-zA-Z0-9]*)))?";
final String string = "customer name is jason estibeiro and customer id is 1234532\n"
+ "customer name is jason estibeiro or customer id is 1234532\n"
+ "customer name is sajal sharma and customer id is 1234532 and policy id is abcd1234\n"
+ "customer name is sajal sharma and customer id is 1234532 or policy id is abcd1234\n"
+ "customer name is sajal sharma or customer id is 1234532 and policy id is abcd1234\n"
+ "customer name is sajal sharma or customer id is 1234532 or policy id is abcd1234\n"
+ "customer name is tarun and policy id is abcd1234\n"
+ "customer name is tarun or policy id is abcd1234\n"
+ "customer name is omkar\n"
+ "customer name is dhiraj nambiar";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}