import re
regex = re.compile(r"customer name is ([\w\s]*?(?=(?:and|or|$)))?(?:(?:(?:and|or) customer id is )(\d*)|c)? ?(?:(?:(?:and|or) policy id is ([a-zA-Z0-9]*)))?", flags=re.MULTILINE)
test_str = ("customer name is jason estibeiro and customer id is 1234532\n"
"customer name is jason estibeiro or customer id is 1234532\n"
"customer name is sajal sharma and customer id is 1234532 and policy id is abcd1234\n"
"customer name is sajal sharma and customer id is 1234532 or policy id is abcd1234\n"
"customer name is sajal sharma or customer id is 1234532 and policy id is abcd1234\n"
"customer name is sajal sharma or customer id is 1234532 or policy id is abcd1234\n"
"customer name is tarun and policy id is abcd1234\n"
"customer name is tarun or policy id is abcd1234\n"
"customer name is omkar\n"
"customer name is dhiraj nambiar")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")