$re = '/.*at \w+\.[A-Z] \(.+\n([\s\S]+\n)*.*(\[as realHandler]|<anonymous>)/';
$str = 'Error
at Logger._s (/var/user/impl/lib/log.js:7:17)
at Logger.I (/var/user/impl/lib/log.js:26:22)
at getWxContext (/var/user/impl/route.js:136:7)
at route (/var/user/impl/route.js:19:13)
at EventHandler.exports.main [as realHandler] (/var/user/index.js:14:22)
at EventHandler.handle (/var/runtime/node8/bootstrap.js:401:28)
at invoke (/var/runtime/node8/bootstrap.js:204:22)
at Timeout.setTimeout [as _onTimeout] (/var/runtime/node8/bootstrap.js:133:9)
at ontimeout (timers.js:475:11)
at tryOnTimeout (timers.js:310:5)';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);