#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\[[^][]+\]\h+=>\h+STRING:\h+"(\w+(?:-\w+)*)""
Local $sString = "[TIMETRA-VRTR-MIB::vRtrIfName.22.178] => STRING: "interface900" "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")