package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[[^][]+\]\h+=>\h+STRING:\h+"(\w+(?:-\w+)*)"`)
var str = `[TIMETRA-VRTR-MIB::vRtrIfName.22.178] => STRING: "interface900" `
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}