using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"START([\s\S]*)END";
string input = @"one two three four START four five four
five sixEND seven";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}