package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)START([\s\S]*)END`)
var str = `one two three four START four five four
five sixEND seven`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}