re = /START([\s\S]*)END/m
str = 'one two three four START four five four
five sixEND seven'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end