package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(?:[^.?!]|https?://[^<>\s"\']++)*?sentence(?:[^.?!]|https?://[^<>\s"\']++)*`)
var str = `I don't want this piece! This is the <a href='https://example.com/my-sentence'>sentence</a> I want. In don't want this piece either`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}