use strict;
my $str = 'I don\'t want this piece! This is the <a href=\'https://example.com/my-sentence\'>sentence</a> I want. In don\'t want this piece either';
my $regex = qr~\b(?:[^.?!]|https?://[^<>\s"\']++)*?sentence(?:[^.?!]|https?://[^<>\s"\']++)*~mup;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}