package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[^\p{L}:]|.[^\p{L}0-9:\-_]|[^\p{L}0-9]$`)
var str = `wdadù
-wdadw
_wdwdawd
23
_33454
.2435
now how
dww
test-now
àwdàawd
wad-àùùdw
test_ok`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}